[ 
https://issues.apache.org/jira/browse/CASSANDRA-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12888367#action_12888367
 ] 

Eric Evans commented on CASSANDRA-1204:
---------------------------------------

There are still a lot of unrelated changes here (mostly things like whitespace, 
brace placement, etc). If you are not putting these patches together with a 
VCS, then I'll accept that this time, but try and avoid that going forward 
since it makes reviewing more difficult and the history less concise.

A few other things:
 * You added the column family name to the maps returned in 
describe_keyspace(), which unless I'm missing something is redundant since the 
outer map is keyed by column family name.
 * The main help synopsis is wrong (wasn't updated for the last command syntax 
changes you made).
 * Help text should wrap at some standardized column width. That has been 80 
chars and while I'd personally like to see us keep it there, something wider is 
possible so long as it is consistent.
 * I'm also not a fan of the conditionals with regular expressions used for 
drilling down to command specific help. It would be better if this were parsed 
with antlr like everything else, and added to the command completer.
 * I'm not sure what to do with the tests you have here. On the one hand, I'd 
love to have tests, but on the other, the need to have an instance already 
running (separately started) is kind of a deal-breaker.

> CliClient Support for add, drop, and rename should be added for keyspace and 
> column family
> ------------------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-1204
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-1204
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 0.7
>            Reporter: Mason Bryant
>            Priority: Minor
>             Fix For: 0.7
>
>         Attachments: cli_new_methods2.diff, cli_new_methods3.diff, 
> cli_new_methods4.diff, cli_unit_tests.diff, cli_unit_tests2.diff
>
>
> Should add support for the add, drop, and rename operations to keyspace and 
> column family in the CliClient.
> Eg:
> add keyspace <keyspace>                                      Add a new 
> keyspace.
> add column family <cf>[comparator]                      Add a new column 
> family.
> drop keyspace <keyspace>                                      Delete a 
> keyspace.
> drop column family <cf>                                  Delete a column 
> family.
> rename keyspace <keyspace>=<keyspace_new_name>                Rename a 
> keyspace.
> rename column family <name>=<new_name>                   Rename a column 
> family.
> Note: I have patch built for this, but drop keyspace corrupts the schema and 
> prevents the node from restarting due to a bug elsewhere (see: CASSANDRA-1203)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to