[ 
https://issues.apache.org/jira/browse/CASSANDRA-8384?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14623843#comment-14623843
 ] 

Aleksey Yeschenko commented on CASSANDRA-8384:
----------------------------------------------

Thanks, this looks good.

Some issues in the patch:
- {{equals()}} is wrong for {{CompressionParameters}}
- {{AlterTest}} and {{CreateTest}} are using old schema tables and keyspaces 
(also, we should not hard code those names anywhere - we have 
{{String.format()}} and {{SystemKeyspace.NAME}}, {{SchemaKeyspace.NAME}}, plus 
constants for all table names - it makes searching for them easier with IDEA)
- {{ThriftConversion.applyImplicitDefaults()}} is setting 
{{CompressionParameters.CLASS}} and not 
{{CompressionParameters.SSTABLE_COMPRESSION}}
- {{LegacySchemaMigratorTest}} is saving compression parameters the new way, 
when it should be using the same Thrift format, used in 2.2 and below.

I've taken some liberty and fixed all of the issues myself, 
[here|https://github.com/iamaleksey/cassandra/commit/522cd7954d161235bb7bb1494a23452896e3994b],
 since they were blocking my other work. Hope you don't mind.

Committed to trunk as {{056115fff93b16071f3fda067329c64dd2fc1f05}}, thanks.

> Change CREATE TABLE syntax for compression options
> --------------------------------------------------
>
>                 Key: CASSANDRA-8384
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8384
>             Project: Cassandra
>          Issue Type: Sub-task
>            Reporter: Aleksey Yeschenko
>            Assignee: Benjamin Lerer
>              Labels: doc-impacting, docs
>             Fix For: 3.0 beta 1
>
>
> Currently, `compression` table options are inconsistent with the likes of it 
> (table `compaction`, keyspace `replication`).
> I suggest we change it for 3.0, like we did change `caching` syntax for 2.1 
> (while continuing to accept the old syntax for a release).
> I recommend the following changes:
> 1. rename `sstable_compression` to `class`, to make it consistent 
> `compression` and `replication`
> 2. rename `chunk_length_kb` to `chunk_length_in_kb`, to match 
> `memtable_flush_period_in_ms`, or, alternatively, to just `chunk_length`, 
> with `memtable_flush_period_in_ms` renamed to `memtable_flush_period` - 
> consistent with every other CQL option everywhere else
> 3. add a boolean `enabled` option, to match `compaction`. Currently, the 
> official way to disable comression is an ugly, ugly hack (see CASSANDRA-8288)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to