[ 
https://issues.apache.org/jira/browse/CASSANDRA-14772?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16865091#comment-16865091
 ] 

Per Otterström commented on CASSANDRA-14772:
--------------------------------------------

Had a look at your patch [~krummas].

Overall it looks good to me. In particular I like the way things are more 
decoupled with the {{QueryEvents}}/{{AuthEvents}}. One thing though, that feels 
a little bit more complicated than necessary is the enable/disable mechanics in 
{{AuditLogManager}}. There is:
* the {{enabled}} flag
* the {{auditLogger}} which can be a {{NoOpAuditLogger}} instance or something 
else
* and now also the registerAsListener()/unregisterAsListener()
Since the listener subscription will make sure that we don't get calls to log() 
when audit logs are disabled, it should now be possible to drop the {{enable}} 
flag without performance impact. What do you think?

A few minor comments:
* {{AuditLogManager}} still has a comment referring to FQL.
* {{AuditLogManager.log(AuditLogEntry)}} has a null-check which I believe is 
unnecessary now. Same in {{AuditLogManager.log(AuditLogEntry, Exception)}}.
* {{AuditLogManager.isAutidLogEnabled}} is still referred to in a comment in 
the class
* Rename {{QueryEventTest}} to {{QueryEventsTest}
* Start the DTests on CirlceCI


> Fix issues in audit / full query log interactions
> -------------------------------------------------
>
>                 Key: CASSANDRA-14772
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-14772
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Legacy/CQL, Legacy/Tools
>            Reporter: Marcus Eriksson
>            Assignee: Marcus Eriksson
>            Priority: Normal
>             Fix For: 4.0
>
>
> There are some problems with the audit + full query log code that need to be 
> resolved before 4.0 is released:
> * Fix performance regression in FQL that makes it less usable than it should 
> be.
> * move full query log specific code to a separate package 
> * do some audit log class renames (I keep reading {{BinLogAuditLogger}} vs 
> {{BinAuditLogger}} wrong for example)
> * avoid parsing the CQL queries twice in {{QueryMessage}} when audit log is 
> enabled.
> * add a new tool to dump audit logs (ie, let fqltool be full query log 
> specific). fqltool crashes when pointed to them.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to