[ https://issues.apache.org/jira/browse/CASSANDRA-17221?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17533927#comment-17533927 ]
Ekaterina Dimitrova commented on CASSANDRA-17221: ------------------------------------------------- I would say - create a new branch, same as Apache Cassandra trunk, then cherry-pick your patch commits on top of it. Normally we use different name for the branches we work on, not keeping the name trunk. It is easier to follow and you keep your trunk aligned with the Apache Cassandra repo trunk instead. As the project is quite alive, you might need to rebase regularly on top of the cassandra trunk branch. Your commits always come on top. Here is a nice tutorial on git rebase you might want to read: [https://www.atlassian.com/git/tutorials/rewriting-history/git-rebase] Let me know if you have any questions. Also, please, be careful not to override your patch in trunk now with force push or something. I suggest you create fresh new branches and cherry-pick what you need from the original one which you can keep for backup. If something is unclear, we can get on a quick call to show you, let me know. > Add Math functions > ------------------- > > Key: CASSANDRA-17221 > URL: https://issues.apache.org/jira/browse/CASSANDRA-17221 > Project: Cassandra > Issue Type: Improvement > Components: CQL/Syntax > Reporter: Benjamin Lerer > Assignee: Simon Chess > Priority: Normal > Labels: AdventCalendar2021, lhf > Fix For: 4.x > > > We should add native Maths functions for the most common operations: > * {{abs\(x)}} returns the absolute value of the x > * {{exp\(x)}} returns the value of e (the base of natural logarithms) raised > to the power of x > * {{log\(x)}} returns the natural logarithm (base e) of x > * {{log10\(x)}} returns the base-10 logarithm of x > * {{round\(x)}} returns the closest integer to x > +Additional information for newcomers:+ > The new functions should be put in a new class {{MathFcts}} similar to > {{TimeFcts}}. > The {{MathsFcts.all()}} method should be called in > {{SystemKeyspace.functions}} > The unit tests for the functions should be put in a {{MathFctsTest}} similar > to {{TimeFctsTest}} -- This message was sent by Atlassian Jira (v8.20.7#820007) --------------------------------------------------------------------- To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org