rangareddy commented on issue #17289: URL: https://github.com/apache/hudi/issues/17289#issuecomment-5365815380
This issue was reviewed as part of the JIRA-migrated backlog triage (HUDI-8373). **Findings: the substance of this has been achieved; only the exact word differs.** The central requirement - *"Do not use startTime, endTime, etc that can cause confusion"* - is met in the file that matters. Searching `hudi-common/src/main/java/org/apache/hudi/common/table/read/IncrementalQueryAnalyzer.java` for `startTime` or `endTime` returns nothing. What the codebase settled on is `startCompletionTime` / `endCompletionTime`: - `IncrementalQueryAnalyzer.java` - 16 occurrences - `CompletionTimeQueryView.java`, `versioning/v2/CompletionTimeQueryViewV2.java` - `hudi-flink-datasource/hudi-flink/.../source/IncrementalInputSplits.java` The ticket asked for `beginCompletionTime`, which has **zero** occurrences anywhere. And `instantTime` / `completionTime` for the timeline concepts are in use as requested. So the ambiguity this ticket was filed to remove is gone; the difference is "start" versus "begin" as the prefix. That is a judgement call, not a defect. Recommend either closing this as substantively done, or narrowing it to a mechanical rename with a stated preference - and if the latter, it is worth doing repo-wide in one pass rather than piecemeal. Keeping this open pending that call. -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
