rangareddy commented on issue #17296: URL: https://github.com/apache/hudi/issues/17296#issuecomment-5365817044
This issue was reviewed as part of the JIRA-migrated backlog triage (HUDI-8419). **Findings: confirmed, and the duplication is sharper than the title suggests - both definitions use the same config key.** - `hudi-client/hudi-client-common/src/main/java/org/apache/hudi/config/HoodiePayloadConfig.java:55-56` - `PAYLOAD_CLASS_NAME` with key `hoodie.compaction.payload.class` - `hudi-common/src/main/java/org/apache/hudi/common/table/HoodieTableConfig.java:268-269` - a second `ConfigProperty` also named `PAYLOAD_CLASS_NAME`, with the **identical** key - `hudi-common/.../HoodieTableConfig.java:275` - a third related definition, `LEGACY_PAYLOAD_CLASS_NAME` Two `ConfigProperty` objects sharing one key, one in a write-config class and one in a table-config class, means the default value, the `withAlternatives` list and any inference are declared twice and can drift apart independently. That makes this a correctness hazard rather than only a readability problem - which is worth reflecting in the ticket, since "simplify" reads as cosmetic. When resolving it, the interesting question is which one wins for a given read: a table property persisted in `hoodie.properties` and a write config resolved from the session should not be able to disagree silently. Keeping this open. -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
