[
https://issues.apache.org/jira/browse/HADOOP-6394?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12791729#action_12791729
]
Hudson commented on HADOOP-6394:
--------------------------------
Integrated in Hadoop-Common-trunk-Commit #120 (See
[http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk-Commit/120/])
. Add a helper class to simplify FileContext related tests and improve code
reusability. Contributed by Jitendra Nath Pandey.
> Helper class for FileContext tests
> ----------------------------------
>
> Key: HADOOP-6394
> URL: https://issues.apache.org/jira/browse/HADOOP-6394
> Project: Hadoop Common
> Issue Type: Improvement
> Components: test
> Affects Versions: 0.21.0, 0.22.0
> Reporter: Jitendra Nath Pandey
> Assignee: Jitendra Nath Pandey
> Fix For: 0.22.0
>
> Attachments: HADOOP-6394.1.patch, HADOOP-6394.2.patch,
> HADOOP-6394.3.patch, HADOOP-6394.5.patch
>
>
> A helper class for FileContext tests should contain common methods which
> can be used in many unit tests, so that every unit test doesn't have to
> re-implement these functionality.
> Examples of such methods:
> createFile(FileContext fc, Path path, int numBlocks, int blockSize) //To
> create a file with number of blocks and block-size passed.
> getTestRootPath(FileContext fc)
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.