[ https://issues.apache.org/jira/browse/HADOOP-13157?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15285484#comment-15285484 ]
Andrew Wang commented on HADOOP-13157: -------------------------------------- 1. If we make it a static helper method, it can go pretty much anywhere. Larry knows this area of the code better than me, but I can search around if that'd help. 2. I'd be happy if we just pin it to a given version of the docs. This is the URL for the 2.7.2 docs, you can expect the 2.8.0 docs to use the same URL format: http://hadoop.apache.org/docs/r2.7.2/ > Follow-on improvements to HADOOP-12942 > -------------------------------------- > > Key: HADOOP-13157 > URL: https://issues.apache.org/jira/browse/HADOOP-13157 > Project: Hadoop Common > Issue Type: Bug > Components: security > Affects Versions: 2.8.0 > Reporter: Mike Yoder > Assignee: Mike Yoder > > [~andrew.wang] had some follow-up code review comments from HADOOP-12942. > Hence this issue. > Ping [~lmccay] as well. > The comments: > {quote} > Overall this looks okay, the only correctness question I have is about the > difference in behavior when the pwfile doesn't exist. > The rest are all nits, would be nice to do these cleanups though. > File > hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/crypto/key/JavaKeyStoreProvider.java: > Line 147: > Could this be a static helper? > Line 161: new > The javadoc says it returns null in this situation. This is also a difference > from the implementation in the AbstractJKSP. Intentional? > Line 175: private void locateKeystore() throws IOException { > static helper? for the construct*Path methods too? > File > hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/crypto/key/KeyShell.java: > Line 50: @VisibleForTesting public static final String NO_VALID_PROVIDERS = > FYI for the future, our coding style is to put annotations on their own > separate line. > File > hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/security/alias/AbstractJavaKeyStoreProvider.java: > Line 326: private char[] locatePassword() throws IOException { > this method looks very similar to the one in JavaKeyStoreProvider, except the > env var it looks for is different, is there potential for code reuse? > Line 394: " o In the environment variable " + > Using a "*" is the usual way of doing a bullet point, e.g. markdown and wiki > syntax. > Line 399: > "http://hadoop.apache.org/docs/current/hadoop-project-dist/" + > This link is not tied to a version, so could be inaccurate. > {quote} -- This message was sent by Atlassian JIRA (v6.3.4#6332) --------------------------------------------------------------------- To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org For additional commands, e-mail: common-issues-h...@hadoop.apache.org