On Sat, 25 Apr 2009, Frederik Holljen wrote: > On 25/04/2009, Tobias Schlitt <[email protected]> wrote: > > > > On 04/24/2009 11:17 PM Frederik Holljen wrote: > > > > > I propose: > > > ezcPersistentSessionBase or Definition for the interface > > > ezcPersistentSessionIdentityDecorator for the decorator > > > > > Somewhat longer but more descriptive and you'll only write it once > > > anyway... > > > > I agree with ezcPersistentSessionIdentityDecorator, that sounds > > good. However, ezcPersistentSessionBase sounds like an abstract > > class not like an interface. > > I agree. What about my other suggestion > ezcPersistentSessionDefinition? I really don't like the idea to name a > class something with object. It messes with the OO definitions.. it's > a class, not an object. Another option is to use foundation: > ezcPersistentSessionFoundation
I like foundation (and the ezcPersistentSessionIdentityDecorator) sounds fine too, although it's a tad (too) long IMO. regards, -- Derick Rethans eZ components Product Manager eZ systems | http://ez.no -- Components mailing list [email protected] http://lists.ez.no/mailman/listinfo/components
