Hi Petr,

The fix looks good to me. We still need a review from someone who maintains the Launcher code. Kumar?

Also, you could use the @autoreleasepool directive to simplify it a bit, although I'm fine with the explicit syntax, too.

One comment regarding your remark:
c. We would have lost all the hg history for this file.

We wouldn't. Mercurial handles renaming of files very well. See `hg help rename` for more details. (I'm not suggesting to rename this file though.)

--
best regards,
Anthony

On 05/21/2013 10:57 AM, David Holmes wrote:
Adding core-libs as this is actually a launcher change.

David

On 21/05/2013 4:36 PM, Petr Pchelko wrote:
Hello, AWT Team.

Please review the fix for the issue:
http://bugs.sun.com/view_bug.do?bug_id=8009911
The webrev is available at:
http://cr.openjdk.java.net/~pchelko/8009911/webrev.00/

The problem:
When launching java with -XstatrOnFirstThread we were using
dispatch_sync to start a Java main on the main thread. This blocked
the main dispatch queue, so all the subsequent calls to GCD were never
invoked. GCD is used a bit in our code, but it is used inside Cocoa,
for example for fullscreen.

The solution:
We now launch Java main using a performSelectorOnMaintThread, so we do
not block GCD.

Notes:
1. This also fixes the following SWT bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=388886
2. Although I have added OBJC syntax into java_md_macosx.c file, I did
not rename it to .m, because:
    a. It is hard to update an old build system to compile with the
new file name.
    b. It is already compiled with -x objective-c, so I will compile
    c. We would have lost all the hg history for this file.

With best regards. Petr.

Reply via email to