On 09/10/2016 08:21 PM, Martin Buchholz wrote: > http://cr.openjdk.java.net/~martin/webrevs/openjdk9/jsr166-jdk9-integration/ > > Mostly docs and tests.
Looks good. Very nice use of (frequently overlooked) local classes in examples. Minor things: CountedCompleter.java: 176 * setPendingCount(1); // not off by one ! is better spelled like this? 176 * setPendingCount(1); // only one pending, not two! SubmissionTest.java: + static long millisElapsedSince(long startTime) { + return (System.nanoTime() - startTime) / (1000L * 1000L); + } ... + if (millisElapsedSince(startTime) >= LONG_DELAY_MS) { I hate these unit conversions sprinkled everywhere. Can it be like this? if (TimeUnit.NANOSECONDS.toMillis(System.nanoTime() - startTime) >= LONG_DELAY_MS) Thanks, -Aleksey