Removed ArrayDeque from patch.
Updated webrev and API

Webrev: http://cr.openjdk.java.net/~jjg/8186684/webrev.01/index.html
API: http://cr.openjdk.java.net/~jjg/8186684/api.01/overview-summary.html

-- Jon

On 08/23/2017 03:29 PM, Martin Buchholz wrote:
Jon, please just drop ArrayDeque. We'll fix it separately by renaming the private add method.

On Wed, Aug 23, 2017 at 3:17 PM, Jonathan Gibbons <jonathan.gibb...@oracle.com <mailto:jonathan.gibb...@oracle.com>> wrote:


    On 08/23/2017 03:12 PM, Martin Buchholz wrote:


    On Wed, Aug 23, 2017 at 3:04 PM, Jonathan Gibbons
    <jonathan.gibb...@oracle.com
    <mailto:jonathan.gibb...@oracle.com>> wrote:


        Although it is not immediately clear in the webrev, the
        underlying characteristic of all places where I had to add an
        empty arg list is that there was a private field of the same
        name in scope.


    I took a closer look at ArrayDeque.  I see no field named "add",
    but I do see

         static final int add(int i, int distance, int modulus) {

    which should probably be renamed anyways, (although overloading
    on arity ought to be safe!  )

    So add() would still have been ambiguous, since there are two
    methods matching?

    Yes, the error in question was reported as:

    docs/api/java/util/ArrayDeque.html:715: id not found:
    add-int-int-int-

indicating that "{@link #add}" had matched the method you noted. Although the method exists, it was not documented because it is
    not a public or protected method: hence the broken link.  If we
    had run javadoc with -package option, that link would have been
    OK, although there would likely have been a gazillion other errors!

    -- Jon



Reply via email to