At Google I spend a lot of time staring unproductively at classloader code,
and it's always hard for me to resist the urge to clean it up.  So here are
some patches that should be relatively uncontroversial, and may prepare for
more radical changes later.

8198480: Improve ClassLoaders static init block
http://cr.openjdk.java.net/~martin/webrevs/jdk/ClassLoaders-static/
https://bugs.openjdk.java.net/browse/JDK-8198480

8198481: Coding style cleanups for
src/java.base/share/classes/jdk/internal/loader/ClassLoaders.java
http://cr.openjdk.java.net/~martin/webrevs/jdk/loader-style/
https://bugs.openjdk.java.net/browse/JDK-8198481

8198482: The URLClassPath field "urls" should be renamed to "unopenedUrls"
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-rename-urls/
https://bugs.openjdk.java.net/browse/JDK-8198482

8198484: URLClassPath should use an ArrayDeque instead of a Stack
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-ArrayDeque/
https://bugs.openjdk.java.net/browse/JDK-8198484

8198485: Simplify a URLClassPath constructor
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-simplify-constructor/
https://bugs.openjdk.java.net/browse/JDK-8198485

Reply via email to