On 2/21/18 12:30 PM, Martin Buchholz wrote:
OK, we have a reworked set of patches.

(In my corner of openjdk we generally use real javadoc on private elements.)

I reverted private doc comment style to the current maddening inconsistency, except I couldn't restrain myself from fixing

-    // ACC used when loading classes and resources */
+    // ACC used when loading classes and resources

I changed ArrayDeque.push to addFirst, as Peter suggested.


8198480: Improve ClassLoaders static init block
http://cr.openjdk.java.net/~martin/webrevs/jdk/ClassLoaders-static/ <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/ClassLoaders-static/>
https://bugs.openjdk.java.net/browse/JDK-8198480


Can you rename initialModuleName to mainModule as Alan suggests (also in the comment)?
line 63-64: ident further to the right as line 62 is the condition.

8198481: Coding style cleanups for src/java.base/share/classes/jdk/internal/loader http://cr.openjdk.java.net/~martin/webrevs/jdk/loader-style/ <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/loader-style/>
https://bugs.openjdk.java.net/browse/JDK-8198481

Looks okay.


8198482: The URLClassPath field "urls" should be renamed to "unopenedUrls"
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-rename-urls/ <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/URLClassPath-rename-urls/>
https://bugs.openjdk.java.net/browse/JDK-8198482


+1

8198484: URLClassPath should use an ArrayDeque instead of a Stack
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-ArrayDeque/ <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/URLClassPath-ArrayDeque/>
https://bugs.openjdk.java.net/browse/JDK-8198484


Looks okay.  I also think no need to have a separate copyToArrayDeque method and just inline in the constructor.

8198485: Simplify a URLClassPath constructor
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-simplify-constructor/ <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/URLClassPath-simplify-constructor/>
https://bugs.openjdk.java.net/browse/JDK-8198485


+1

Mandy

Reply via email to