yes - $ROOTDIR now means what $APPDIR used to, and this method gets $ROOTDIR/app/ , so getCfgAppDir() is still the right name.

/Andy

On 10/8/2019 3:23 PM, Philip Race wrote:
      protected String getCfgAppDir() {
- return Path.of("$APPDIR").resolve(
- ApplicationLayout.linuxAppImage().appDirectory()).toString() + File.separator;
+ return Path.of("$ROOTDIR").resolve(
+ ApplicationLayout.linuxAppImage().appDirectory()).toString()
+ + File.separator;

Do you really want to leave the method name unchanged ?

-phil.

On 10/8/19, 12:06 PM, Andy Herrick wrote:
Please review the jpackage fix for bug [1] at [2].

This is a fix for the JDK-8200758-branch branch of the open sandbox repository (jpackage).

This change is to Expose the macro $APPDIR for use in --java-options value, to rename macros to mean what they are called, and to eliminate several unused macros.

[1] https://bugs.openjdk.java.net/browse/JDK-8231910

[2] http://cr.openjdk.java.net/~herrick/8231910/

/Andy

Reply via email to