On Thu, 29 Jul 2021 18:21:07 GMT, Lance Andersen <lan...@openjdk.org> wrote:

>> Hi,
>> 
>> As discussed in the 
>> https://mail.openjdk.java.net/pipermail/core-libs-dev/2021-July/079621.html 
>> thread, this is the revised patch to address the use of '.' and '..' within 
>> Zip FS
>> 
>> Zip FS needs to use "." and ".." as links to the current and parent 
>> directories and cannot reliably support entries that have "." and ".." as 
>> name elements.  This patch updates Zip Fs  to reject ZIP files that have 
>> entries in the CEN that can't be used for files in a file system.
>> 
>> 
>> Mach5 tiers 1 through 3 have been run without any errors encountered .
>> 
>> Best,
>> Lance
>
> Lance Andersen has updated the pull request with a new target base due to a 
> merge or a rebase. The incremental webrev excludes the unrelated changes 
> brought in by the merge/rebase. The pull request contains six additional 
> commits since the last revision:
> 
>  - Add Impl Note to Zip FS module-info
>  - Merge
>  - Add missing Copyright header and address minor comments
>  - Address missing linefeed  after package name
>  - Address overzelous intellij import update
>  - Patch to address JDK-8251329

src/jdk.zipfs/share/classes/module-info.java line 49:

> 47:  *
> 48:  * @implNote The Zip File System will throw a ZipException when opening an
> 49:  * existing Zip file that contains Zip entries with "." or ".." in its 
> name elements.

Hello Lance, reading this sentence adds a bit of confusion since it uses the 
word "contains". Had I not known the implemenation details, this sentence would 
have made me think zip file with name elements of the form `foo.bar` or 
`hello..`  would also be rejected since these name elements "contain" `.` or 
`..`

Do you think we should change the word to something like "The Zip File System 
will throw a ZipException when opening an existing Zip file that has "." or 
".." named entries"?

-------------

PR: https://git.openjdk.java.net/jdk/pull/4900

Reply via email to