On Thu, 22 Jun 2023 00:19:03 GMT, Joe Darcy <da...@openjdk.org> wrote:

> Small cleanup, minor differences in the wording of portions of 
> toString(Object, String), nonNull(Object), requireNonNullElse, and 
> requireNonNullElseGet.

Looks good. I had to refresh my understanding of the exact behavior of the 
inline `@return` tag:

https://docs.oracle.com/en/java/javase/17/docs/specs/javadoc/doc-comment-spec.html

(search for `{@return`)

It adds a leading "Returns " and a trailing "." to the block's text, and 
inserts a "Returns" section in the proper place. This seems oddly specific, but 
it's tailored for this exact use case. Anyway, good cleanup.

-------------

Marked as reviewed by smarks (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/14608#pullrequestreview-1492140246

Reply via email to