> Please review this PR which is a broad clean up of the DigitList class (used 
> by Format classes in j.text).
> 
> This PR is intended to be a portion of a bigger change (split up to make 
> reviewing easier). 
> 
> The main change combines related Rounding Mode logic in `shouldRoundUp()` - 
> (_CEILING/FLOOR_, _HALF_UP/DOWN/EVEN_)
> 
> Other changes include
> - Certain for loops can be replaced with cleaner syntax (E.g. for(;;), empty 
> for loops)
> - Introduce `roundInt(int)` - For use by Integer representations of DigitList
> - Introduce `nonZeroAfterIndex(int)` - To reduce code duplication

Justin Lu has updated the pull request incrementally with one additional commit 
since the last revision:

  Reflect review comments (8/11/23)

-------------

Changes:
  - all: https://git.openjdk.org/jdk/pull/15252/files
  - new: https://git.openjdk.org/jdk/pull/15252/files/207db250..c9782b77

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jdk&pr=15252&range=01
 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=15252&range=00-01

  Stats: 46 lines in 1 file changed: 8 ins; 10 del; 28 mod
  Patch: https://git.openjdk.org/jdk/pull/15252.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/15252/head:pull/15252

PR: https://git.openjdk.org/jdk/pull/15252

Reply via email to