Rename createJavaProcessBuilder so that it is not used by mistake instead of 
createTestJvm.

I have used the following sed script: `find -name "*.java" | xargs -n 1 sed -i 
-e "s/createJavaProcessBuilder(/createJavaProcessBuilderIgnoreTestJavaOpts(/g"`

Then I have manually modified ProcessTools.java. In that file I have moved one 
version of createJavaProcessBuilder so that it is close to the other version. 
Then I have added a javadoc comment in bold telling:

   /**
     * Create ProcessBuilder using the java launcher from the jdk to
     * be tested.
     *
     * <p><b> Please observe that you likely should use
     * createTestJvm() instead of this method because createTestJvm()
     * will add JVM options from "test.vm.opts" and "test.java.opts"
     * </b> and this method will not do that.
     *
     * @param command Arguments to pass to the java command.
     * @return The ProcessBuilder instance representing the java command.
     */


I have used the name createJavaProcessBuilderIgnoreTestJavaOpts because of the 
name of Utils.prependTestJavaOpts that adds those VM flags. If you have a 
better name I could do a rename of the method. I kind of like that it is long 
and clumsy, that makes it harder to use...

I have run tier 1 testing, and I have started more exhaustive testing.

-------------

Commit messages:
 - 8315097: Rename createJavaProcessBuilder

Changes: https://git.openjdk.org/jdk/pull/15452/files
 Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=15452&range=00
  Issue: https://bugs.openjdk.org/browse/JDK-8315097
  Stats: 756 lines in 462 files changed: 22 ins; 10 del; 724 mod
  Patch: https://git.openjdk.org/jdk/pull/15452.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/15452/head:pull/15452

PR: https://git.openjdk.org/jdk/pull/15452

Reply via email to