On Thu, 26 Sep 2024 23:46:04 GMT, Joe Darcy <da...@openjdk.org> wrote:

> The is the initial version of a PR to defined an anchor point and index term 
> of "wrapper classes."

src/java.base/share/classes/java/lang/package-info.java line 36:

> 34:  * The <dfn>{@index "wrapper classes"}</dfn> {@link Boolean},
> 35:  * {@link Character}, {@link Short}, {@link Integer}, {@link Long}, 
> {@link Float},
> 36:  * and {@link Double} serve this purpose.  An object of type {@code

Somehow, `Byte` is missing from that list. To be fair, it had been missing 
before this PR.

src/java.base/share/classes/java/lang/package-info.java line 45:

> 43:  * These classes also provide
> 44:  * a number of methods for converting among primitive values, as well
> 45:  * as supporting such standard methods as {@code equals} and {@code 
> hashCode}.  The

While the bulk of this sentence has unchanged, it read weirdly because of it's 
non-parallel structure:

"These classes ... provide ... methods for converting ..., as well as 
supporting ... methods ... equals and hashCode."

Consider these alternatives:

1. "These classes ... provide ... methods for converting ..., as well as 
support ... methods ... equals and hashCode."

2. "These classes ... provide ... methods for converting ..., as well as for 
supporting ... functionality of equals and hashCode."

src/java.base/share/classes/java/lang/package-info.java line 63:

> 61:  * security policies.
> 62:  *
> 63:  * <p>Class {@link Throwable} encompasses objects that may be thrown

We already have a link to `Class` in this doc comment. This one can stay 
`{@code Class}`, which might be easier to read.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/21215#discussion_r1778306710
PR Review Comment: https://git.openjdk.org/jdk/pull/21215#discussion_r1778326694
PR Review Comment: https://git.openjdk.org/jdk/pull/21215#discussion_r1778311130

Reply via email to