On Fri, 14 Aug 2026 08:46:23 GMT, Alan Bateman <[email protected]> wrote:

>> Leonid Mesnik has updated the pull request incrementally with one additional 
>> commit since the last revision:
>> 
>>   updated after feedback in PR
>
> test/jdk/jdk/internal/vm/ThreadSnapshot/ThreadLockClassInit.java line 40:
> 
>> (failed to retrieve contents of file, check the PR for context)
> The user facing API is HotSpotDiagnosticMXBean.dumpThreads which has tests 
> with threads owning, blocking or waiting on monitors. It's okay to add to 
> test for ThreadSnapshot for this case here but I think it will need a better 
> name (and summary) as this is not a general test for ThreadSnapot with 
> threads owning monitors.

Thanks for info, as I wrote the jcmd tests also test how threaddump is 
generated for threads with monitors. 

However it was easier to write this test is regression test for 8378071.  
I verifies  I renamed it to 'ThreadLockClassInit' which is exactly what it is 
supposed to test.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32363#discussion_r3787145837

Reply via email to