On Wed, 19 Aug 2026 13:56:07 GMT, Per Minborg <[email protected]> wrote:

>> Naoto Sato has updated the pull request incrementally with four additional 
>> commits since the last revision:
>> 
>>  - Merge remote-tracking branch 'jdk-sandbox/json' into 
>> JDK-8381976-Implementation-for-Simple-JSON-API
>>  - Use \u instead of 0x for code point prefix
>>  - Get rid of StringBuilder.insert(0, ... in path building
>>  - Reflects reviews
>
> src/jdk.incubator.json/share/classes/jdk/incubator/json/impl/JsonValueImpl.java
>  line 31:
> 
>> 29:  * Used for JsonValueException error message building.
>> 30:  */
>> 31: public sealed interface JsonValueImpl
> 
> It is a bit unusual that an interface is named `...Impl`. Is there a better 
> name we can use for this class?

Good point. I will come up with a better name

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32282#discussion_r3814561007

Reply via email to