On Tue, 8 Sep 2026 15:16:03 GMT, Pavel Rappo <[email protected]> wrote:
>> I believe the correct word is MUST, as in required/necessary. Here's the
>> reason (* is mine):
>>
>>
>> class InverseAnalyzeDeps extends AnalyzeDeps {
>> InverseAnalyzeDeps() {
>> }
>>
>> @Override
>> boolean checkOptions() {
>> if (options.recursive != -1 || options.depth != -1) {
>> reportError("err.invalid.options", "--recursive and
>> --no-recursive", "--inverse");
>> return false;
>> }
>>
>> if (options.numFilters() == 0) { // *
>> reportError("err.filter.not.specified");
>> return false;
>> }
>>
>>
>> As for the grammar, I was going to fix it in "This option must use with
>> --require ..." when it occurred to me to compare that bit with that of
>> manpage. The manpage wording was good, so I copied it verbatim.
>
> Heh, it's even simpler:
>
> % jdeps --inverse
>
>
> Error: --package (-p), --regex (-e), --require option must be specified
Right. No good way to express `--inverse ===> (--package || --require ||
--regex)` but `(--package || --require || --regex) =/=> --inverse` without some
convoluted wording. I guess `must` is good enough. I see you fixed the
`directly and indirectly` wording in the man page too.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/32701#discussion_r3959547374