> One more thing.  I think the create_class method should simply use the
> package name of its caller, rather than take one explicitly, and should
> probably be renamed "create_methods".  It's going to be used by format
> module writers who'll do:
>
>  package DateTime::Format::Gobbledygook;
>
>  use DateTime::Format::Builder;
>
>  DateTime::Format::Builder->create_methods( ... );

Dave++

I really prefer composition over inheritance.  Fewer [unexpected] land mines.

-J

--

Reply via email to