On 5/30/16 12:55 PM, Kyle Huey wrote:
Segregating the thread-specific and thread-agnostic parts into
separate classes seems like a good idea.

Just to be clear, that's pretty much all internal stuff. From the perspective of an API consumer (Gecko), there is really only the thread-specific thing in spidermonkey API.

Put another way, as far as I can tell, SpiderMonkey will continue to have an API where there is some thing (name not clear yet, but currently it's called JSRuntime) that maps to some specific thread of the embedding. That thread is the only embedder thread allowed to touch anything to do with that JSRuntime. SpiderMonkey will internally create various helper threads (e.g. for JIT compilation) which may touch some things that may or may not live on JSRuntime; this is the part still being decided. But from the point of view of the embedding, all that stuff doesn't even exist.

Given that it only makes sense to use a thread-specific object on that
thread, and it only makes sense to get the thread-agnostic object here
*from TLS* on one thread, I don't think we need any "thread" naming.

OK.  So what do you propose we name things?

-Boris

_______________________________________________
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform

Reply via email to