Daniel Fagerstrom wrote:
More specifically I propose is that we extend o.a.c.environment.Request with:

 Map getAttributes();
 Map getParameters();
 Map getHeaders();

What about cookies? (There is Map getCookieMap() but naming convention is different).



and o.a.c.environment.Session and o.a.c.environment.Context with:

Map getAttributes();

What about Session interface?

Is there any cruft accumulated in there which can be deprecated? (like getCookieMap?).

How above Request interface additions will relate to methods already added to 2.2 interface:

    Object getAttribute(String name, int scope);
    Object searchAttribute(String name);
    Enumeration getAttributeNames(int scope);
    void setAttribute(String name, Object o, int scope);
    void removeAttribute(String name, int scope);

Can any of those be renamed / reworked to be consistent with the proposed additions? As we had no single 2.2 release yet, it's good time to review those additions.


[+1] Go ahead and implement the environment extensions proposed above.

Please take above into account as well - I don't want to end up with too porky interface.


Vadim

Reply via email to