On 12/13/10 4:39 PM, Stefan Seelmann wrote:
Hi dev,

our current partition implementations use different fields/methods to
configure the location where partition data is persisted:
- BTreePartition defines a 'partitionDir' with getter/setter, this is
used by the JdbmPartition
- AbstractLdifPartition defines a 'workingDirectory' with
getter/setter, this is used by LdifPartition
- SingleFileLdifPartition defines a 'ldifFile' which is set by the constructor

I'd like to propose to remove the existing fields and to add a new
'partitionLocation' (or partitionPath? better names welcomed) field
including getter/setter instead:
- for JdbmPartition and LdifPartition this points to a directory in file system
- for SingleFileLdifPartition this points to the single LDIF file in file system
Sounds good to me. How do you handle the different kind of underlying types though ?



--
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com

Reply via email to