[ 
https://issues.apache.org/jira/browse/FELIX-2280?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Christian Müller updated FELIX-2280:
------------------------------------

    Attachment: FELIX-2280.patch

Me again...
I provide a new patch (based on the current trunk) which respects your 
requirements:

1) OracleJDBCLock:
 - We perform only a "SELECT FOR UPDATE" in the lock() and in the isAlive() 
method. This works for Oracle and will hopefully not overflow the UNDO table 
space for long running instances.

2) DefaultJDBCLock:
 - Provides the same functionality like the current implementation (add the 
";create=true" jdbc url option to a derby connection url, if they is not 
provided by the user).

3) DerbyJDBCLock:
 - New Lock implementation for Derby. Also set the ";create=true" jdbc url 
option, if they is not provided by the user

4) MySQLJDBCLock:
 - Provides the same functionality like the current implementation, but in a 
more elegant way (add the ";createDatabaseIfNotExist=true" jdbc url option, if 
they is not provided by the user).

I hope that's what you want. Sometime, my brain is a bit slow... :o)

Cheers,
Christian

> To much code duplication in DefaultJDBCLock, OracleJDBCLock and MySQLJDBCLock
> -----------------------------------------------------------------------------
>
>                 Key: FELIX-2280
>                 URL: https://issues.apache.org/jira/browse/FELIX-2280
>             Project: Felix
>          Issue Type: Improvement
>          Components: Karaf
>    Affects Versions: karaf-1.4.0
>         Environment: All
>            Reporter: Christian Müller
>         Attachments: FELIX-2280.patch, FELIX-2280.patch, FELIX-2280.patch
>
>
> org.apache.felix.karaf.main.DefaultJDBCLock, 
> org.apache.felix.karaf.main.MySQLJDBCLock and 
> org.apache.felix.karaf.main.OracleJDBCLock has to much code duplications. I 
> propose a solution like in ActiveMQ [package 
> org.apache.activemq.store.jdbc.adapter|http://svn.apache.org/viewvc/activemq/trunk/activemq-core/src/main/java/org/apache/activemq/store/jdbc/adapter/].
> And we should implement some unit tests for it.
> If it's fine for you, I will try to improve this part of karaf and provide a 
> patch for it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to