[ https://issues.apache.org/jira/browse/HIVE-2646?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13227746#comment-13227746 ]
Phabricator commented on HIVE-2646: ----------------------------------- cwsteinbach has requested changes to the revision "HIVE-2646 [jira] Hive Ivy dependencies on Hadoop should depend on jars directly, not tarballs". INLINE COMMENTS testutils/hadoop:50 If $HIVE_TEST_CLASSPATH is not set we should throw an error and exit instead of using a hardcoded default classpath. testutils/hadoop:47 I think we should change the name of this env var to something like HIVE_HADOOP_TEST_CLASSPATH in order to make it clear that we're using it with bin/hadoop. build-common.xml:409 Let's make it possible to override this value by adding test.hadoop.bin.path=${hive.root}/testutils/hadoop to build.properties, and then reference ${test.hadoop.bin.path} here. build-common.xml:384 This is probably causing some test failures since some tests expect hive-contrib-*.jar to *not* be on the classpath. I think we should create a classpath specifically for passing to the bin/hadoop consisting of the hive jars, the hadoop jars, and relevant dependencies, and not include hive-contrib-*.jar. build-common.xml:79 alphabetical order? ivy/common-configurations.xml:24 Are 'hadoop20' and 'hadoop23' compile configurations? If so can we change the name to 'hadoop20.compile' and 'hadoop23.compile', and change the names of the test configurations to "hadoop20.test" and "hadoop23.test", or something that's consistent? pdk/scripts/build-plugin.xml:36 Please define ivy.lib.default.dir and reference that instead. REVISION DETAIL https://reviews.facebook.net/D2133 BRANCH HIVE-2646-dev-branch > Hive Ivy dependencies on Hadoop should depend on jars directly, not tarballs > ---------------------------------------------------------------------------- > > Key: HIVE-2646 > URL: https://issues.apache.org/jira/browse/HIVE-2646 > Project: Hive > Issue Type: Bug > Components: Build Infrastructure > Affects Versions: 0.8.0 > Reporter: Andrew Bayer > Assignee: Andrew Bayer > Priority: Critical > Attachments: HIVE-2646.D2133.1.patch, HIVE-2646.D2133.10.patch, > HIVE-2646.D2133.2.patch, HIVE-2646.D2133.3.patch, HIVE-2646.D2133.4.patch, > HIVE-2646.D2133.5.patch, HIVE-2646.D2133.6.patch, HIVE-2646.D2133.7.patch, > HIVE-2646.D2133.8.patch, HIVE-2646.D2133.9.patch, HIVE-2646.diff.txt > > > The current Hive Ivy dependency logic for its Hadoop dependencies is > problematic - depending on the tarball and extracting the jars from there, > rather than depending on the jars directly. It'd be great if this was fixed > to actually have the jar dependencies defined directly. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa For more information on JIRA, see: http://www.atlassian.com/software/jira