[ https://issues.apache.org/jira/browse/HIVE-2804?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13269295#comment-13269295 ]
Phabricator commented on HIVE-2804: ----------------------------------- cwsteinbach has requested changes to the revision "HIVE-2804 [jira] Task log retrieval fails on secure cluster". INLINE COMMENTS ql/src/java/org/apache/hadoop/hive/ql/exec/FunctionRegistry.java:255 This doesn't belong here. The UDF is for testing purposes only. Users should not see it listed in the output of 'SHOW FUNCTIONS'. ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFNPE.java:1 @Namit: Good point. @Zhenxiao: Please put this in ql/src/test/org/apache/hadoop/hive/ql/udf/generic, and then take a look at ql/src/test/queries/clientpositive/create_genericudf.q for an example of how to register a temporary UDF. ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFNPE.java:37 Might be good to change the name to "evaluate_npe" (and update the other comments accordingly) just to make it clear that the NPE is thrown in evaluate() as opposed to initialize(). ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFNPE.java:49 I'm curious if this if() block is really necessary. Does the Java compiler complain without it? ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFNPE.java:42 Is it possible to write a GenericUDF that takes no input parameters (e.g. like UDFPI)? If so then I think we should do that here since we ignore the input anyway. If that isn't possible, then please change this to take a string as input since that will work better with the src table. ql/src/test/queries/clientnegative/cluster_npe_tasklog.q:3 Referencing src_thrift may give people the impression that this test is somehow related to Thrift. Let's use the src table instead. ql/src/test/queries/clientnegative/cluster_npe_tasklog.q:1 Please change the name to "cluster_tasklog_retrieval.q". shims/src/0.20/java/org/apache/hadoop/hive/shims/Hadoop20Shims.java:529 Can we call TaskLogServlet.getTaskLogUrl() here instead of manually constructing the URL? If the answer is no then please add a comment explaining why. Thanks. shims/src/0.20S/java/org/apache/hadoop/hive/shims/Hadoop20SShims.java:33 Same question as above. shims/src/0.23/java/org/apache/hadoop/hive/shims/Hadoop23Shims.java:38 Please use the getHost() and getPort() methods that are provided by java.net.URL. REVISION DETAIL https://reviews.facebook.net/D3057 BRANCH HIVE-2804 > Task log retrieval fails on secure cluster > ------------------------------------------ > > Key: HIVE-2804 > URL: https://issues.apache.org/jira/browse/HIVE-2804 > Project: Hive > Issue Type: Bug > Components: Diagnosability, Query Processor, Security > Reporter: Carl Steinbach > Assignee: Zhenxiao Luo > Attachments: HIVE-2804.1.patch.txt, HIVE-2804.D3057.1.patch > > -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa For more information on JIRA, see: http://www.atlassian.com/software/jira