[
https://issues.apache.org/jira/browse/KAFKA-1634?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14152466#comment-14152466
]
Joel Koshy commented on KAFKA-1634:
-----------------------------------
[~nehanarkhede] I agree that timestamp in the request API is a bit odd since
that is an implementation detail on the server-side (on how long to retain
offsets) and setting "future" timestamps on the client-side is a hack to
"trick" the server into retaining the offset.
The use-cases though are as Jun described - i.e., if a client wants to ensure
that offsets are retained for a certain period of time (regardless of when the
server cleans up stale offsets). That said, the field could be renamed and
reimplemented as a retentionPeriod field (not timestamp). i.e., if set the
consumer would explicitly say "retain my offsets for X
milliseconds/days/whatever". The broker can have a second hard staleness
threshold to cap this client-driven staleness threshold.
> Update protocol wiki to reflect the new offset management feature
> -----------------------------------------------------------------
>
> Key: KAFKA-1634
> URL: https://issues.apache.org/jira/browse/KAFKA-1634
> Project: Kafka
> Issue Type: Bug
> Reporter: Neha Narkhede
> Assignee: Jun Rao
> Priority: Blocker
> Fix For: 0.8.2
>
>
> From the mailing list -
> following up on this -- I think the online API docs for OffsetCommitRequest
> still incorrectly refer to client-side timestamps:
> https://cwiki.apache.org/confluence/display/KAFKA/A+Guide+To+The+Kafka+Protocol#AGuideToTheKafkaProtocol-OffsetCommitRequest
> Wasn't that removed and now always handled server-side now? Would one of
> the devs mind updating the API spec wiki?
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)