[ 
https://issues.apache.org/jira/browse/LUCENE-2691?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12920601#action_12920601
 ] 

Earwin Burrfoot commented on LUCENE-2691:
-----------------------------------------

bq. As I said above, though, I'm fine w/ dropping the reopen one and just 
keeping open(IW). 
Let's do this.

In my ideal world the semantics of each method is encoded in its name.
So 'open' - always gets you a brand new reader on a given target, while 
'reopen' updates the one you have.
Due to snapshot nature of readers, you don't do update inplace and get a new 
instance instead, but that doesn't make these two methods' semantics the same.

> Consolidate Near Real Time and Reopen API semantics
> ---------------------------------------------------
>
>                 Key: LUCENE-2691
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2691
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Grant Ingersoll
>            Assignee: Grant Ingersoll
>            Priority: Minor
>             Fix For: 4.0
>
>         Attachments: LUCENE-2691.patch, LUCENE-2691.patch
>
>
> We should consolidate the IndexWriter.getReader and the IndexReader.reopen 
> semantics, since most people are already using the IR.reopen() method, we 
> should simply add::
> {code}
> IR.reopen(IndexWriter)
> {code}
> Initially, it could just call the IW.getReader(), but it probably should 
> switch to just using package private methods for sharing the internals

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to