[ 
https://issues.apache.org/jira/browse/SOLR-6022?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13983829#comment-13983829
 ] 

Tomás Fernández Löbbe commented on SOLR-6022:
---------------------------------------------

I don't see why in 4x calls to getAnalyzer() can't be changed to 
getIndexAnalyzer(), It wouldn't break compatibility and it would avoid creating 
many warnings. 

> Rename getAnalyzer to getIndexAnalyzer
> --------------------------------------
>
>                 Key: SOLR-6022
>                 URL: https://issues.apache.org/jira/browse/SOLR-6022
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Ryan Ernst
>         Attachments: SOLR-6022.branch_4x-deprecation.patch, SOLR-6022.patch, 
> SOLR-6022.patch
>
>
> We have separate index/query analyzer chains, but the access methods for the 
> analyzers do not match up with the names.  This can lead to unknowingly using 
> the wrong analyzer chain (as it did in SOLR-6017).  We should do this 
> renaming in trunk, and deprecate the old getAnalyzer function in 4x.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to