[
https://issues.apache.org/jira/browse/SOLR-6022?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13985257#comment-13985257
]
Anshum Gupta commented on SOLR-6022:
------------------------------------
Good stuff. Makes things easier to comprehend.
I am not sure if this should be the IndexAnalyzer or the QueryAnalyzer as
AFAIR, this tries to construct a query out of the terms from a document (given
an id).
{code:title= MoreLikeThisHandler.java|borderStyle=solid}
- mlt.setAnalyzer( searcher.getSchema().getAnalyzer() );
+ mlt.setAnalyzer( searcher.getSchema().getIndexAnalyzer() );
{code}
> Rename getAnalyzer to getIndexAnalyzer
> --------------------------------------
>
> Key: SOLR-6022
> URL: https://issues.apache.org/jira/browse/SOLR-6022
> Project: Solr
> Issue Type: Improvement
> Reporter: Ryan Ernst
> Attachments: SOLR-6022.branch_4x-deprecation.patch, SOLR-6022.patch,
> SOLR-6022.patch, SOLR-6022.patch
>
>
> We have separate index/query analyzer chains, but the access methods for the
> analyzers do not match up with the names. This can lead to unknowingly using
> the wrong analyzer chain (as it did in SOLR-6017). We should do this
> renaming in trunk, and deprecate the old getAnalyzer function in 4x.
--
This message was sent by Atlassian JIRA
(v6.2#6252)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]