[ 
https://issues.apache.org/jira/browse/LUCENE-5325?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Alan Woodward updated LUCENE-5325:
----------------------------------
    Attachment: LUCENE-5325.patch

Waking this one up again.  Here's a patch that takes into account the new doc 
values iterator API.  The new classes look like this:

DoubleValuesSource
- getDoubleValues(LeafReaderContext, Scorer) which returns a DoubleValues

DoubleValues
- advanceTo(doc) : returns true if doc has a value
- doubleValue() 

And similar for LongValuesSource/LongValues.  There is already a LongValues 
class in lucene.util, so this probably needs a better name.  The XValuesSource 
classes have a bunch of static methods for generating sources from doc values 
fields or from a Scorer.

I also have patches that convert to and from the old ValueSource API, and that 
migrate the facet, expression and suggest modules, but I think they should be 
kept for follow-up issues.


> Move ValueSource and FunctionValues under core/
> -----------------------------------------------
>
>                 Key: LUCENE-5325
>                 URL: https://issues.apache.org/jira/browse/LUCENE-5325
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: core/search
>            Reporter: Shai Erera
>         Attachments: LUCENE-5325.patch, LUCENE-5325.patch, LUCENE-5325.patch, 
> LUCENE-5325.patch, LUCENE-5325.patch
>
>
> Spinoff from LUCENE-5298: ValueSource and FunctionValues are abstract APIs 
> which exist under the queries/ module. That causes any module which wants to 
> depend on these APIs (but not necessarily on any of their actual 
> implementations!), to depend on the queries/ module. If we move these APIs 
> under core/, we can eliminate these dependencies and add some mock impls for 
> testing purposes.
> Quoting Robert from LUCENE-5298:
> {quote}
> we should eliminate the suggest/ dependencies on expressions and queries, the 
> expressions/ on queries, the grouping/ dependency on queries, the spatial/ 
> dependency on queries, its a mess.
> {quote}
> To add to that list, facet/ should not depend on queries too.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to