[ 
https://issues.apache.org/jira/browse/LUCENE-8113?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16307943#comment-16307943
 ] 

Robert Muir commented on LUCENE-8113:
-------------------------------------

Can we fold this into TermContext directly rather than subclassing? 

I think this class is already too complicated for any performance benefits it 
brings us. If we add subclassing it sets it over the edge a bit. 

Can we also try to think of a better name for it? I really like this change in 
the patch:

{noformat}
- public TermState get(int ord) {
+ public TermState get(LeafReaderContext ctx) throws IOException {
{noformat}

But because both things are named *Context (which to me is a meaningless name), 
it leads to confusing looking code such as:
{noformat}
TermState termState = termContext.get(context);
{noformat}

Also there are quite a few changes to how ScoreModes are passed during query 
construction in the patch. Looks correct, but is that supposed to be here?

> Allow terms dictionary lookups to be lazy when scores are not needed
> --------------------------------------------------------------------
>
>                 Key: LUCENE-8113
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8113
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Alan Woodward
>         Attachments: LUCENE-8113.patch
>
>
> LUCENE-7311 made it possible to avoid loading TermStates in cached 
> TermQueries.  It would be useful to extend this to other queries that use the 
> terms dictionary.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to