[
https://issues.apache.org/jira/browse/LUCENE-8483?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16604369#comment-16604369
]
David Smiley commented on LUCENE-8483:
--------------------------------------
+1 looks good Alan. If you want to standardize on the name ScoreAndDoc as a
common stereotype of Scorable, then DummyScorer in CollapsingQParserPlugin
ought to be named this as well. It's curious to see so many of these impls. I
wonder if the name "ScoreAndDoc" is best; perhaps "BasicScorable"?
"ScoreAndDoc" doesn't incorporate Scorable which is suggestive one fo those two
names should be different so that it aligns better.
> Enforce that Scorer cannot have a null Weight
> ---------------------------------------------
>
> Key: LUCENE-8483
> URL: https://issues.apache.org/jira/browse/LUCENE-8483
> Project: Lucene - Core
> Issue Type: New Feature
> Reporter: Alan Woodward
> Assignee: Alan Woodward
> Priority: Major
> Attachments: LUCENE-8483.patch, LUCENE-8483.patch, LUCENE-8483.patch
>
>
> Follow up to LUCENE-6228. All Scorers that were passing null as their parent
> Weights can be replaced by Scorables, so we can now enforce that Scorer must
> not have a null Weight.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]