[
https://issues.apache.org/jira/browse/SOLR-12365?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16735033#comment-16735033
]
ASF subversion and git services commented on SOLR-12365:
--------------------------------------------------------
Commit 84264c7410a04390e79a5248e4d0492c88ec191d in lucene-solr's branch
refs/heads/master from David Wayne Smiley
[ https://git-wip-us.apache.org/repos/asf?p=lucene-solr.git;h=84264c7 ]
SOLR-12365: moved parseLuceneVersionString to SolrConfig class
> Rename Config.java to XmlConfigFile.java to clarify it's use
> ------------------------------------------------------------
>
> Key: SOLR-12365
> URL: https://issues.apache.org/jira/browse/SOLR-12365
> Project: Solr
> Issue Type: Improvement
> Security Level: Public(Default Security Level. Issues are Public)
> Reporter: David Smiley
> Priority: Minor
> Attachments:
> move_luceneMatchVersion_parsing_to_SolrConfig_from_XmlConfigFile.patch
>
>
> Seeing "Config"; I was confused what sort of config it was. Turns out it's a
> wrapper around an XML document providing some convenience methods around it.
> It ought to have class javadocs too. XmlConfigFile would be a clearer name
> IMO.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]