[
https://issues.apache.org/jira/browse/SOLR-4998?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13700443#comment-13700443
]
Otis Gospodnetic commented on SOLR-4998:
----------------------------------------
bq. http://www.elasticsearch.org/guide/reference/glossary/
Much simpler and cleaner, IMHO:
* primary shard
* replica shard
So in ES a primary shard is a real physical thing and a replica is a real
physical thing as well.
I think that's easier than saying a shard is a logical concept and that inside
a shard there are replicas, but some are called leaders and others are
called....well, replicas.
This also allows the Collection (Index in ES terminology) creation API to take
num_shards and num_replicas parameters, which is less confusing than agreeing
what replicationFactor means - is it the total number of replicas in a shard or
the number of non-leader replicas.
It may be too late to change this in SolrCloud now even if everyone agreed...
> Make the use of Slice and Shard consistent across the code and document base
> ----------------------------------------------------------------------------
>
> Key: SOLR-4998
> URL: https://issues.apache.org/jira/browse/SOLR-4998
> Project: Solr
> Issue Type: Improvement
> Components: SolrCloud
> Affects Versions: 4.3, 4.3.1
> Reporter: Anshum Gupta
>
> The interchangeable use of Slice and Shard is pretty confusing at times. We
> should define each separately and use the apt term whenever we do so.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]