> On Oct. 16, 2014, 4:38 a.m., Timothy Chen wrote:
> > 3rdparty/libprocess/3rdparty/stout/tests/path_tests.cpp, line 25
> > <https://reviews.apache.org/r/26766/diff/1/?file=722432#file722432line25>
> >
> >     Without starting to look at what RoundTrip does I really have no clue 
> > what it means, since it doesn't really suggest splitting the string and 
> > testing that the joining also works.
> >     
> >     I'm horrible with names, but I just think naming it resembles string 
> > functions it's calling is easier to understand. Don't you think something 
> > like EXPECT_SPLIT_EQ_JOIN("a", vector<string>({"a"}) is easier to 
> > understand at first glance than RoundTrip?

roundTrip is the standard terminology for a cycle to something and back. Note 
that the roundTripReduce explicitly isn't checking that they produce the same 
reuslts.


- Cody


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26766/#review56883
-----------------------------------------------------------


On Oct. 23, 2014, 4:52 p.m., Cody Maloney wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/26766/
> -----------------------------------------------------------
> 
> (Updated Oct. 23, 2014, 4:52 p.m.)
> 
> 
> Review request for mesos, Ben Mahler and Timothy Chen.
> 
> 
> Bugs: MESOS-1878
>     https://issues.apache.org/jira/browse/MESOS-1878
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> Adds 3 new functions: asAbsolute, clean, and split(). All three were 
> hand-coded inside of mesos files (files/files.cpp). This puts them in a 
> common place, and adds unit tests for their behavior.
> 
> The functions depend on eachother somewhat, so I pulled out the declarations 
> to make them all forward declared.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/3rdparty/stout/include/stout/path.hpp 
> 357a75a8bac497465671456aa9cd9181123cc635 
>   3rdparty/libprocess/3rdparty/stout/tests/path_tests.cpp 
> aedf93573ea89e46bf7b7b91f2258049af2fd79f 
> 
> Diff: https://reviews.apache.org/r/26766/diff/
> 
> 
> Testing
> -------
> 
> make distcheck
> 
> 
> Thanks,
> 
> Cody Maloney
> 
>

Reply via email to