I would like to add a parameter to ShoppingCart.addOrIncreaseItem(... , boolean checkItemsExists)
I see that the method signature is already pretty long. I would like to know if instead would it be a better idea to pass along a Map object around instead? If there is already an existing effort to reduce the number of parameters I would like to see how you are dealing with it.
