My favorite current proposal is to super-simplify that method and then
on the ShoppingCartItem object that it returns just call additional
methods to add additional data. That way now, and in the future, we
only have to add setters to ShoppingCartItem to support new data there.
-David
On Dec 22, 2008, at 3:51 PM, Stephen Rufle wrote:
I would like to add a parameter to
ShoppingCart.addOrIncreaseItem(... ,
boolean checkItemsExists)
I see that the method signature is already pretty long. I would like
to
know if instead would it be a better idea to pass along a Map object
around instead?
If there is already an existing effort to reduce the number of
parameters I would like to see how you are dealing with it.