[ 
https://issues.apache.org/jira/browse/QPID-7409?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15648202#comment-15648202
 ] 

Alex Rudyy commented on QPID-7409:
----------------------------------

Keith,
I reviewed your changes and here are my review comments.
# MessageContentJsonConverter.NoneBase64ByteArraySerializer; in java byte range 
is -128,127. I think that converter should transform bytes values to be in 
range from 0 to 256.
# css
** I see that declaration of class '.hexDumpRow' includes '.hexDumpRow;'. I am 
not sure that specifying of other css class within another css class is 
supported by all browsers.
** IMHO, we should give preference to "em" units over "px" when defining 
padding/marging/etc. 
# HexDumpWidget
** I find property 'width' a bit misleading as generally it implies to css 
width style. Would it be better to rename width into columnsNumber or 
columnsCount or numberOfColumns or columns? 
** hexDumpBox floats to the left.  I did not test it in all browsers but I 
expect that it might screw the layout in some browsers, as css clear is not 
used.
** I am curious whether html table markup could suite here better than divs? Is 
it because rendering of divs is faster than rendering of table?
# showMessage.js
** Number.isInteger is supported in IE starting from v12. I think we are still 
aiming to be backward compatible with IE10.
**  The preview widget creation: byte range in java is -128 to 127. Thus, byte 
message with negative bytes are displayed as a list message (dgrid). Object 
messages are also displayed as a list...
** Seeing hex dump widget header for empty message is confusing... May be we 
should not display preview in this case...
** For the list message we should stringify the list item only when it is an 
object. I think we should change  item generation for preview widget as below
{code}value: typeof contentData[i] === "object" ? 
json.stringify(contentData[i]) : contentData[i]{code}
** 'jqson.parse' looks like type. Did you mean json.parse

> Support preview of maps/list message content
> --------------------------------------------
>
>                 Key: QPID-7409
>                 URL: https://issues.apache.org/jira/browse/QPID-7409
>             Project: Qpid
>          Issue Type: Improvement
>            Reporter: Keith Wall
>            Assignee: Keith Wall
>             Fix For: qpid-java-6.1
>
>         Attachments: 
> 0001-QPID-7409-Java-Broker-Move-responsibility-to-limit-m.patch, 
> 0001-QPID-7409-Java-Broker-WMC-Limit-the-message-content-.patch, 
> 0001-QPID-7409-WIP-add-support-for-getting-of-message-con.patch
>
>
> When viewing messages through the web management console, if the message is 
> of type such as a list or map currently the user sees the bytes of the 
> underlying AMQP datastructure.  Instead, the preview area should display the 
> data in a human friendly way.
> The managed operation {{Queue#getMessageContent}} will be enhanced to be 
> capable of returning a message in JSON format if possible with an optional 
> parameter {{returnJson}}.  If rather than returning the message's content 
> bytes directly, it should first convert the message to an {{InternalMessage}} 
> (MessageConverterRegistry.getConverter(serverMessage.getClass, 
> InternalMessage.class).convert(...)) then use the JSON serialiser to serial 
> the MessageBody of the resulting internal message.
> Within the WMC, if the resulting object is of a previewable type (string, 
> map, list etc) and the content is not too long, the content should be added 
> to a scrollable preview pane of the message dialogue by traversing the object 
> tree and producing a human readable representation of its structure and 
> content.  (Perhaps an approach such as 
> https://stackoverflow.com/questions/13341373/render-arbitrary-json-in-html 
> will help)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@qpid.apache.org
For additional commands, e-mail: dev-h...@qpid.apache.org

Reply via email to