Hi Jan,

> === Renaming Service ===
> Rename AuthenticationController to EntitlementService(Impl), since
> containing methods have little to nothing to do with authentication. It is 
> only
> about Entitlements...

+1 for Entitlement, -1 for Service. I would keep names consistently, if use 
EntitlementService name, than rename all controllers to services inclusive 
package name (but I suggest to do it on the later phase).

> 
> === Changing response Type ===
> listEntitlements() returns a List<String> whereas getEntitlements() returns a
> Set<String>.
> 
> Option 1:
> <EntitlementTOs>
>    <EntitlementTO>ROLE_ADMIN</EntitlementTO>
>    <EntitlementTO>ROLE_SUPERUSER</EntitlementTO>
> </EntitlementTOs>
> 
> Option 2:
> <EntitlementTOs>
>    <EntitlementTO>
>       <name>ROLE_ADMIN</name>
>   </EntitlementTO>
>    <EntitlementTO>
>       <name> ROLE_SUPERUSER </name>
>   </EntitlementTO>
> </EntitlementTOs>

+1 for Option 2

> And what I forgott to mention: listEntitlements and getEntitlements are not 
> very self-explanatory. A better name would be getAllEntitlements and 
> getMyEntitlements.

+1

Cheers,
Andrei.

Reply via email to