[ 
https://issues.apache.org/jira/browse/THRIFT-3416?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15005462#comment-15005462
 ] 

Jens Geyer commented on THRIFT-3416:
------------------------------------

{code:title=testcase.thrift}
// either one of the following decls should produce an error and stop the 
Thrift compiler with an adequate "unsupported" message.

cpp_namespace "this should not work anymyore"
php_namespace "this should not work anymyore"
ruby_namespace "this should not work anymyore"
xsd_namespace "this should not work anymyore"
csharp_namespace "this should not work anymyore"
delphi_namespace "this should not work anymyore"

py_module "this should not work anymyore"
java_package "this should not work anymyore"
perl_package "this should not work anymyore"
smalltalk_category "this should not work anymyore"
smalltalk_prefix "this should not work anymyore"
cocoa_prefix "this should not work anymyore"
{code}



> Retire old "xxx_namespace" declarations from the IDL
> ----------------------------------------------------
>
>                 Key: THRIFT-3416
>                 URL: https://issues.apache.org/jira/browse/THRIFT-3416
>             Project: Thrift
>          Issue Type: Improvement
>          Components: Compiler (General)
>            Reporter: Jens Geyer
>
> While poking into the IDL syntax, I found that hidden gem:
> {code}
> | tok_xsd_namespace tok_literal
>     {
>       pwarning(1, "'xsd_namespace' is deprecated. Use 'namespace xsd' 
> instead");
>       pdebug("Header -> tok_xsd_namespace tok_literal");
>       declare_valid_program_doctext();
>       if (g_parse_mode == PROGRAM) {
>         g_program->set_namespace("cocoa", $2);   // what ... COCOA ?!?
>       }
>     }
> {code}
> While thinking whether I should do sth about it, I came to the conclusion 
> that the time ist right to "_Get rid of this_" since today probably really 
> "_everyone is using the new hotness_", as the comments say.
> Opinions?
> If there are no objections, I'll provide a patch to convert the warnings into 
> an error and remove the rest of it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to