This is an automated email from the ASF dual-hosted git repository.
markt-asf pushed a commit to branch 10.1.x
in repository https://gitbox.apache.org/repos/asf/tomcat.git
The following commit(s) were added to refs/heads/10.1.x by this push:
new 6d802acb03 Align with 11.0.x
6d802acb03 is described below
commit 6d802acb03f687836532aec0381a9bd4d460ac05
Author: Mark Thomas <[email protected]>
AuthorDate: Fri Oct 2 17:24:50 2026 +0100
Align with 11.0.x
---
java/org/apache/catalina/core/LocalStrings.properties | 4 ++--
java/org/apache/catalina/ha/backend/LocalStrings.properties | 2 +-
java/org/apache/catalina/ha/deploy/LocalStrings.properties | 2 +-
java/org/apache/catalina/security/LocalStrings.properties | 6 +++---
java/org/apache/tomcat/util/security/LocalStrings.properties | 2 +-
5 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/java/org/apache/catalina/core/LocalStrings.properties
b/java/org/apache/catalina/core/LocalStrings.properties
index 4686bc5d75..d10c1bacb6 100644
--- a/java/org/apache/catalina/core/LocalStrings.properties
+++ b/java/org/apache/catalina/core/LocalStrings.properties
@@ -74,13 +74,13 @@ applicationHttpRequest.sessionEndAccessFail=Exception
triggered ending access to
applicationPushBuilder.methodInvalid=The HTTP method for a push request must
be both cacheable and safe but [{0}] is not
applicationPushBuilder.methodNotToken=HTTP methods must be tokens but [{0}]
contains a non-token character
+applicationServletRegistration.ise=Servlet [{0}] deployed to context with name
[{1}] can''t be modified after the context has been initialised
applicationServletRegistration.nullInitParam=Unable to set initialisation
parameter for servlet due to null name and/or value. Name [{0}], Value [{1}]
applicationServletRegistration.nullInitParams=Unable to set initialisation
parameters for servlet due to null name and/or value. Name [{0}], Value [{1}]
applicationServletRegistration.nullUrlPattern=URL patterns must not be null or
empty
+applicationServletRegistration.nullUrlPatterns=Null or empty URL patterns
specified for servlet [{0}] deployed to context with name [{1}]
applicationServletRegistration.setServletSecurity.iae=Null constraint
specified for servlet [{0}] deployed to context with name [{1}]
applicationServletRegistration.setServletSecurity.ise=Security constraints
can''t be added to servlet [{0}] deployed to context with name [{1}] as the
context has already been initialised
-applicationServletRegistration.ise=Servlet [{0}] deployed to context with name
[{1}] can''t be modified after the context has been initialised
-applicationServletRegistration.nullUrlPatterns=Null or empty URL patterns
specified for servlet [{0}] deployed to context with name [{1}]
applicationSessionCookieConfig.ise=Property [{0}] cannot be added to
SessionCookieConfig for context [{1}] as the context has been initialised
diff --git a/java/org/apache/catalina/ha/backend/LocalStrings.properties
b/java/org/apache/catalina/ha/backend/LocalStrings.properties
index 40bfde6419..9fd4db435d 100644
--- a/java/org/apache/catalina/ha/backend/LocalStrings.properties
+++ b/java/org/apache/catalina/ha/backend/LocalStrings.properties
@@ -35,7 +35,7 @@ tcpSender.invalidHeaderLine=Unable to parse header line [{0}]
tcpSender.invalidProxyList=Invalid proxy list
tcpSender.notInitialized=Not initialized
tcpSender.readError=Error reading response content
-tcpSender.responseError=Unable to read response from proxy
tcpSender.resolveFailed=Unable to re-resolve proxy [{0}], using the previously
resolved address
+tcpSender.responseError=Unable to read response from proxy
tcpSender.responseErrorCode=Response error with code [{0}]
tcpSender.sendFailed=Unable to send collected load information to proxy
diff --git a/java/org/apache/catalina/ha/deploy/LocalStrings.properties
b/java/org/apache/catalina/ha/deploy/LocalStrings.properties
index 5491936b65..bf8598ccb2 100644
--- a/java/org/apache/catalina/ha/deploy/LocalStrings.properties
+++ b/java/org/apache/catalina/ha/deploy/LocalStrings.properties
@@ -28,10 +28,10 @@ farmWarDeployer.hostParentEngine=FarmWarDeployer can only
work if parent of [{0}
farmWarDeployer.mbeanNameFail=Cannot construct MBean object name for engine
[{0}] and host [{1}]
farmWarDeployer.modInstall=Installing webapp [{0}] from [{1}]
farmWarDeployer.modInstallFail=Unable to install WAR file
-farmWarDeployer.noWatchDir=The watchDir attribute must be set when
watchEnabled is true. Watching for WAR file changes is disabled.
farmWarDeployer.msgIoe=Unable to read farm deploy file message.
farmWarDeployer.msgRxDeploy=Receive cluster deployment path [{0}], war [{1}]
farmWarDeployer.msgRxUndeploy=Receive cluster undeployment from path [{0}]
+farmWarDeployer.noWatchDir=The watchDir attribute must be set when
watchEnabled is true. Watching for WAR file changes is disabled.
farmWarDeployer.removeFailLocal=Local remove from [{0}] failed
farmWarDeployer.removeFailRemote=Local remove from [{0}] failed, other manager
has app in service!
farmWarDeployer.removeLocal=Removing webapp [{0}]
diff --git a/java/org/apache/catalina/security/LocalStrings.properties
b/java/org/apache/catalina/security/LocalStrings.properties
index c7630e19f2..2a42d116f1 100644
--- a/java/org/apache/catalina/security/LocalStrings.properties
+++ b/java/org/apache/catalina/security/LocalStrings.properties
@@ -16,7 +16,7 @@
# Do not edit this file directly.
# To edit translations see:
https://tomcat.apache.org/getinvolved.html#Translations
-SecurityListener.buildDateAgeUnreadable=Unable to read configured
buildDateWarningAgeDays [{0}], using default of [{1}] days.
+SecurityListener.buildDateAgeUnreadable=Unable to read configured
buildDateWarningAgeDays [{0}], keeping the previously configured value
(default: [{1}] days).
SecurityListener.buildDateIsOld=This version of Tomcat was built more than {0}
days ago. You should consider upgrading to the current version.
SecurityListener.buildDateUnreadable=Server build date [{0}] is unreadable as
an ISO-8601 date.
SecurityListener.checkUmaskFail=Start attempted with umask setting of [{0}].
Running Tomcat without a umask at least as restrictive as [{1}] has been
blocked by the Lifecycle listener org.apache.catalina.security.SecurityListener
(usually configured in CATALINA_BASE/conf/server.xml)
@@ -29,6 +29,6 @@ SecurityUtil.doAsPrivilege=An exception occurs when running
the PrivilegedExcept
listener.notServer=This listener must only be nested within Server elements,
but is in [{0}].
-tlsCertRenewalListener.notRenewed=[{0}], TLS virtual host [{1}] with name
[{2}] that expires on [{3}] is overdue for renewal
+tlsCertRenewalListener.notRenewed=[{0}], TLS virtual host [{1}] certificate
with subject [{2}] that expires on [{3}] is overdue for renewal
tlsCertRenewalListener.reloadFailed=[{0}], TLS virtual host [{1}] reload of
TLS configuration failed
-tlsCertRenewalListener.reloadSuccess=[{0}], TLS virtual host [{1}] reloaded
TLS configuration
+tlsCertRenewalListener.reloadSuccess=[{0}], TLS virtual host [{1}] attempted
to reload TLS configuration
diff --git a/java/org/apache/tomcat/util/security/LocalStrings.properties
b/java/org/apache/tomcat/util/security/LocalStrings.properties
index 1d938379c7..2fe474a2a2 100644
--- a/java/org/apache/tomcat/util/security/LocalStrings.properties
+++ b/java/org/apache/tomcat/util/security/LocalStrings.properties
@@ -16,7 +16,7 @@
# Do not edit this file directly.
# To edit translations see:
https://tomcat.apache.org/getinvolved.html#Translations
-concurrentMessageDigest.noDigest=Digest algorithm unavailable
+concurrentMessageDigest.noDigest=Digest algorithm not initialized or
unavailable
privilegedSetAccessControlContext.lookupFailed=Unable to obtain reference to
field Thread.inheritedAccessControlContext
privilegedSetAccessControlContext.setFailed=Unable to set field
Thread.inheritedAccessControlContext
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]