On Feb 20, 10 11:31, Andrei Alexandrescu wrote:
Justin Johansson wrote:
Nick Sabalausky wrote:
"dave eveloper" <ta...@land.net> wrote in message
news:hlm402$1mr...@digitalmars.com...
Ezneh Wrote:

So, it is not better to find a compromise between these libraries ?
Why they have to be "two" libraries rather than one which was
designed by larsivi, Walter Bright and Andrei Alexandrescu ?
I haven't seen larsivi around lately. Is it possible that there's a
communication problem? Perhaps a personality mismatch?

Because of silly symbol names like 'retro' I think there's more
reason for someone to not like Phobos. Bearophile also always
reminds us that a proper closure inlining support would make
collection algorithms as fast as the ugly string template hack
Phobos. That way you wouldn't have hard coded parameter symbols like
a and b.


Dictionary.com Unabridged, Based on the Random House Dictionary:

retro-

a prefix occurring in loanwords from Latin meaning “backward”
(retrogress); on this model, used in the formation of compound words
(retrorocket).

So can we stop this "retro is a bad name" nonsense now?

Sure, just include a copy of, or link to, an English dictionary
alongside D documentation, together with appropriate annotations.

My understanding is that he included it to clarify that it's an
appropriate word, not to explain a rare word such as "nefandous".

That's tantamount to what you are saying. imho, use of "silly"
words like this in the language are a retrograde step.

This is the third time I'm asking: what is a list of allegedly silly
names in phobos? Far as I can tell the case against "retro" and "iota"
is rather tenuous. So what are others? readText? topN? setDifference?
Talk to me.


Andrei

Major silly names:

 - std.file.slurp
 - std.iterator.retro, std.range.retro
 - std.random.dice (it is a discrete distribution...)
 - std.range.cons
 - std.range.iota
 - std.string.chomp, chompPrefix, chop
 - std.string.munch
 - std.string.sformat
 - std.utf.stride (which is totally different from std.range.stride)

Minor annoyances:

- std.contracts.enforceEx (sounds like Win32 API which you should use in favor of enforce.)
 - std.path.rel2abs (why not relToAbs?)
 - std.range.sameHead (should be sameFront?)
- std.stream.Stream.readBlock & writeBlock (sounds like blocking vs non-blocking operations, esp. for SocketStream.)
 - and many inconsistent naming conventions, e.g.
    * std.string.ljustify vs stripl
    * std.string.countchars (all lower) vs inPattern (CamelCase)

Reply via email to