On 2011-05-29 10:25, Jose Armando Garcia wrote:
> Thanks. Comments below.
> 
> On Sun, May 29, 2011 at 12:44 PM, Andrei Alexandrescu
> <seewebsiteforem...@erdani.org> wrote:
> > 4. initLogging and initializeLogging are highly confusing names. Overload
> > them to share the same name, or rename one.
> 
> Yeah. I don't like this either but if I remember correctly D/dmd
> doesn't let me overload a function with a template. I'll look into
> this again. Maybe I can figure out a way to make initLogging a
> template and hence rename initializeLogging.

Generally, the fix to that is to templatize the function which isn't 
templatized. That could mean templatizing its argument and then using template 
constrains to enforce that it's exactly the same type that it was before 
rather than increasing the number of types that it can take, but it does fix 
the overloading problem. Still, dmd really should be fixed to get rid of this 
issue.

- Jonathan M Davis

Reply via email to