> There are two issues at play here: > 1) The collision of method names. > 2) The sheer number of methods attached to the jQuery object.
> #1 will only be solved through a change in the name of the methods > (for example, from .load() to .onload() or .event.load()). > #2 can only be solved by breaking up the bulk of functions into > multiple plugins. For example, simply breaking off the events plugin > from core will release 100 method names. Additionally, none of these > plugin's method names would conflict with each other - they'd be > entirely separate. (This would be taken care of ahead of time by #1) The other way to handle the event case is just to make the event the first argument. It eliminates the namespace problem by putting the namespace in the first arg. That's pretty much what bind() does now. It's a question of whether $().event.load(...) or $().bind("load",...) is shorter and/or prettier. If we're looking for min size, I would suggest .on(), .un(), and .on1() for event handling. Yes they are a bit cryptic but they are very short and pretty intuitive; nearly every jQuery developer will use them a LOT and learn them early. _______________________________________________ jQuery mailing list discuss@jquery.com http://jquery.com/discuss/