John Resig wrote:
>> e.g.:
>> $( '.b0rp' ).filter( '#blap' ).on.click( function() { $( '#foo'
>> ).ajax.load( ... ) } );
> 
> Why no just do .onclick() and .ajaxLoad() - like what was proposed?
> Not only is it fundamentally easier to write and understand, but it's
> easier to implement too.
> 
> The feasibility of 'namespacing' hasn't been brought up yet - but
> leave it to be said that it would be really really difficult and add a
> ton of overhead to the jQuery base as a whole (in order to continue
> chainability support).
> 
> AJAX functionality is the one exception where I think a prefix is
> going to help. Instead of doing .get(), .post(), or .load() - having
> .ajaxGet(), .ajaxPost(), and .ajaxLoad() simply makes more sense.

Why not just .request(method, options) or .http()

After all AJAX is just a bottle of toilet cleaner ;), and a bit
of a misnomer as a lot of calls don't even involve the X(ML).

- Mark.


_______________________________________________
jQuery mailing list
discuss@jquery.com
http://jquery.com/discuss/

Reply via email to